https://netsuiteprofessionals.com logo
#content-alerts
Title
# content-alerts
m

Md Faizi

04/08/2022, 9:51 AM
Can we use classes and objects in Suitescript.I am getting while trying to declare class.Please assist me on this.
r

Ramanand Dubey

04/08/2022, 9:52 AM
Which version u are working on?
m

Md Faizi

04/08/2022, 9:56 AM
2.x
r

Ramanand Dubey

04/08/2022, 9:59 AM
What preference you are using in ns account 2.0 or 2.1
Or you should use 2.1 in your script file
m

Md Faizi

04/08/2022, 10:56 AM
2.0
Will class will work with 2.1 ?
message has been deleted
Thanks brother 🙏
It worked with 2.1
s

scottvonduhn

04/08/2022, 12:54 PM
At this point, I don’t recommend using
2.x
or
2.X
, it’s always better to exactly specify what version you are targeting (
2.0
or
2.1
), otherwise you don’t know whether the script will execute as 2.1 or 2.0. It is especially problematic if you use 2.1 features, as they simply won’t work if the script executes as 2.0.
m

Md Faizi

04/08/2022, 1:33 PM
Thanks for ur suggestion man
5 Views