Is there anyone who is able to DEPLOY SDF project ...
# sdf
Is there anyone who is able to DEPLOY SDF project from this configuration • MacOS • Webstorm (latest) • SDF Plugin (latest) The same project with the same tokens works normal from Ubuntu and latest versions of WebStorm and SDF
Did you verify that the same deployment project is selected?
deployment project? what do you mean? I can validate the project, but can't deploy it. I suspect on Mac version of WebSrorm and SDF but how to get out from black hole? It doesn't work
Sorry, I meant the account.
yes, of course. I tried to solve problem with recreation of tokens, even with re-install of SuiteCloud bundle to reset integration record and tokens... with custom developer role.... and the most important thing : it worked and suddenly stop with errors I shared here. I created the totaly new project and have been trying to deploy to 4 different accounts : it works only for one of them and guess what = only that one is a demo!
It seems to be limited to MacOS. I am on Windows with latest WS and SDF. All good.
🤢 1
I haven't had issues on mac with webstorm 2021.3.3 and sdf plugin 2022.1.1. I authenticate via browser vs manually setting up tokens. Have you tried browser based authentication? Is SDF and token based auth enabled in the account?
I use browser based authentication
Yes, SDF and token based auth are always enabled.
Can you revert to a previous version of WS?
yeah you can. you should be able to download a previous version. Have you been able to successfully deploy to the accounts before?
I will try with the previous version of WS and the latest of SDF....
@Matt Bernstein, yes i was ableto deploy... I reviewed SuiteCloud deploymen log and there is also failed row... it seems to started a month ago. In the meantime I have been waiting for the new version of WS and SDF... but 😭
have you tried to see if you experience the same issue with the suitecloud cli?
Or is there any permission restriction on the filecabinet folder the files are being deployed to?
Can you try with Admin role and see if it works?
Copy code
Info -- Account [(SANDBOX) VOZZi Holding BV]
Info -- Account Customization Project [L9DunRestart]
Info -- Framework Version [1.0]
Validate manifest -- Success
Validate deploy file -- Success
Validate configuration -- Success
Validate objects -- Success
Validate files -- Success
Validate folders -- Success
Validate translation imports -- Success
Validation of referenceability from custom objects to translations collection strings in progress. -- Success
Validate preferences -- Success
Validate flags -- Success
Validate for circular dependencies -- Success
Validate account settings -- Success
Validate Custom Objects against the Account -- Success
Validate file cabinet items against the account -- Success
Validate translation imports against the account -- Success
Validation of references to translation collection strings against account in progress. -- Success
Begin deployment
*** ERROR ***

An unexpected error has occurred.
Details: Access denied

2022-04-22 03:27:47 (PST) Installation FAILED (0 minutes 1 second)
@Ali Syed (NS DevTools QA)
@Zoran R-DATAGRAM It's not a problem with which OS you are using. This problem seems to be coming from account role perms. You said it works from ubuntu -> Are you sure you are using same token in Ubuntu and in Mac? Can you try Admin account and see if you get same error?
Ok I see you already tried Admin role
Can you goto account settings and send me a screenshot of this authid info. Probably DM?
Default DEVELOPER ROLE has not permission to access “Web Site Hosting Files” folder in FileCabinet. But, if you create new project with WebStorm and SDF Plugin, it will be created automatically under FileCabinet and deployment will be failed with “Access denied” I have no idea how to solve this. The best option is remove this folder from the project. Thanks a lot to @Ali Syed (NS DevTools QA) for help.